
Menus

This chapter provides a description of all of the menu items in ToDo List. Use the 
Quick Start chapter to get started with ToDo List and use this chapter as a 
reference when you need details about a particular command.

The Apple Menu

The Apple menu contains only one item specific to ToDo List:

About ToDo List...

This menu item displays the About Box dialog:

 

f you have not purchased your copy of ToDo List there will be a Register button as 
seen above. Clicking this button will step you through the process of buying the 
software. In the future you may re-register your copy by double-clicking your 
name. See the chapter on Registering, for additional information.

ToDo List is distributed as a “fat application” or "fat binary", which means that it 
includes instructions (binary code) for both the original 680x0-based Macintoshes 
and the new Power Macintoshes. While including the binary code for both machine
types makes ToDo List as efficient as possible on either machine, it also makes the 
application a bit larger. 



If you know that you will only ever be using it on one type of Macintosh, you can 
use the Remove Unused button to strip away the code that isn’t needed for the type
of Macintosh that ToDo List is currently running on. This operation cannot be 
undone – keep a backup copy of the original application. If you have already 
preformed this step the button will be removed. Also this button will be disabled if 
the application is locked or is running from a locked volume or a server.

If you want to find out which version of ToDo List you have without launching it, 
select it in the Finder and choose Get Info from the File menu. The information 
window tells you the version number (e.g. 1.0) and whether it is a “Fat” , “680x0” 
or “Power Mac Only” application.

If you use Remove Unused when running on an original 680x0-based Macintosh, it
will eliminate the “native” Power Macintosh code. This modified version of ToDo 
List will still work on Power Macintoshes, it just won’t be as efficient as the 
original. On the other hand, if you use Remove Unused when running on a Power 
Macintosh, the modified version will only work on Power Macintoshes. If you try 
to use in on a non-Power Macintosh, you’ll get a warning and the application 
won’t launch.

The File Menu
The File menu contains commands that apply to ToDo List documents:
 

ew...
Use the New... command to create a new ToDo List document. A new window will 
be created with the default name "untitled". If a document with that name is 



already open, ToDo List will add a number to the end to make a unique name. Any 
changes you make to the document won't be saved until you select Save or Save 
As... from the File menu. At that time you'll be presented with a standard file 
dialog box.    A new document's characteristics are set by the Edit menu's "Default 
Document Settings..." menu item which is available when there are no open 
documents.

Open...
The Open... menu command lets you open an existing ToDo List document. The 
contents of the document are displayed in a new window. The location and size of 
the window are automatically set to be the same as the last time the document was 
open.

If the "Carry Forward Unfinished Items" preference is set for this document (see 
the Preferences section), then as the document is opened, any items with a date 
prior to the current date that have not been checked off will be moved to the 
current date. If the “Display Overdue Days” preference is set, the number of days 
each carried forward item was overdue will be displayed next to the item’s 
checkbox.

Close
Select Close to close the active ToDo List document. If there are any changes to 
the document that haven't been saved yet, you'll be asked if you want to save the 
changes. If the "Automatically Save Changes At Close/Quit" preference is set, you 
won't be asked and the changes will just be saved.

This command will close the Find Dialog if it is the currently active window.

Save
Select Save to save any changes to the active document. This item is only enabled 
if you've made changes since opening or last saving the document.

Save As...
Select Save As... to save the active document as a new document.

Revert
Selecting Revert will cause ToDo List to discard any changes made to the active 
document since it was opened or the last time it was saved. This operation cannot 
be undone, so be careful. This command is only enabled if the document currently 
has unsaved changes. 



Save All Windows
Saves changes in all of the open documents. This item is only enabled if you've 
made changes since opening or last saving at least one document.

Page Setup...
The Page Setup command displays the standard page setup dialog for the currently 
selected printer. If a horizontal page orientation is selected, ToDo List prints two 
mini-pages of items on a single page. If the vertical page orientation is selected, 
ToDo list prints four mini-pages of items per page.

Print...
The Print... command displays a dialog box asking for the range of items to be 
printed from the currently active ToDo List document.

You can select "All" or only those items that fall between selected dates. You can 
also specify a title to appear at the top of each page. 

Preferences...
Selecting "Preferences" displays a dialog box listing all of the current user 
preferences. These preferences apply to the ToDo List application as a whole. See 
the Preferences section for more details.

Quit
Select Quit to quit from ToDo List. If the "Auto-Open Documents On Startup" 
preference is set (see the Preferences section), ToDo List will remember which 
documents were open.

If any of the currently open documents have unsaved changes, you'll be asked if 
you want to save them. If the "Automatically Save at Close/Quit" preference is set, 
then they will be saved without asking.

The Edit Menu
 



ndo <last-command> or Redo <last-command>
Almost all actions in ToDo List can be "undone" and "redone" again if desired. 
This menu item is constantly updated to indicate what the last action was. This 
item is only enabled when the last action occurred in the currently active 
(frontmost) window.

Cut
The currently selected item or items are copied to the clipboard and removed from 
the list. This menu command is only enabled when one or more items are selected. 
ToDo List supports command-clicking for discontinuous selections, shift-clicking 
to extend the selection, etc.

Copy
The currently selected item or items are copied to the clipboard. This menu 
command is only enabled when one or more items are selected. 

Paste
The current contents of the clipboard are inserted into the ToDo List document at 
the position determined by their date (if dates are displayed), or at the current date 
(usually the end of the list). If plain text is in the clipboard, a new item is created 
with the default date and the text is truncated to 255 characters if necessary.    
Unlike other Macintosh applications, Paste will not replace selected items.

Clear
The currently selected item or items are removed from the list. If the "Confirm 
Deletes" preference is set, ToDo List will ask you if you're sure you want to delete 
the item(s) before proceeding.

Select All
This command selects all of the items in the list

Select Finished
This command selects all of the finished items in the list.    This is useful if you 
want to get rid of the finished items in the list, but you still want to keep a copy of 
them somewhere.    Use this command to select all of the finished items.    Then use
the Cut command to copy them to the clipboard and remove them from this list.    
Finally, switch to another ToDo List document (one you’ve created just for 
archiving finished items) and select Paste.



Document Settings...
This command displays a dialog box that lets you adjust a variety of options for the
active (front-most) ToDo List document.    For instance, some documents can 
display dates while others do not. If no ToDo List documents are currently open, 
then menu command changes to Default Document Settings... and it will let you 
change the default settings for new documents. (see Preferences & Document 
Settings)

The Item Menu

 

nsert New Item...
A dialog box will appear in which you can type the text of the new item (see the 
Creating/Editing Items section in Getting Started). The date defaults to the last date
you’ve used or today's date. To start a new line in the text of the item, hold down 
the Option, Shift, or Control key while pressing the Return key. Just pressing 
Return alone will be treated as a click on the OK button (note that this behavior 
can be reversed if you frequently use multi-line items -- see Preferences).

Edit Item...
Select this command to change the text or date of an item. A dialog box like the 
one used by the New Item... command will appear. This command is only enabled 
when only one item is selected (highlighted).

Toggle Finished Status
This command reverses the “finished” status of the selected item or items. If an 
item doesn’t have a check mark next to it, this command will check it off. If the 
item is already checked (finished), then this command unchecks it. This menu 
command is only enabled when one or more items are selected. ToDo List supports
command-clicking for discontinuous selections, shift-clicking to extend the 



selection, etc.

Toggle Priority Status
This command reverses the priority status of the selected item or items. Priority 
items selected become non-priority, and any non-priority items selected will 
become priority items.    Note that when the items change priority status, some of 
them may move up or down in the list so that priority items remain at the top of 
each day (or the top of the list if dates aren’t being displayed). This menu 
command is only enabled when one or more items are selected. ToDo List supports
command-clicking for discontinuous selections, shift-clicking to extend the 
selection, etc.

Find...
To search for some text in the ToDo List window, select the "Find..." command. A 
dialog like the following will be displayed:

 

ou can leave the Find Dialog displayed while switching between other ToDo List 
windows.    Click the Find button to begin a search or find the next item that 
matches.    The search applies to the ToDo List document that is front-most.    If 
Search Backward is set, the search will start at the end of the list and work back to 
the start of the list. Note that ToDo List currently does not include the dates in the 
search when dates are displayed in the window. Comparisons are made using the 
international facilities built in to the Macintosh, so they should match correctly for 
the current country.    Click the Find All button to have ToDo List go through the 
entire list of items and select every item that matches the search string.

Find Again or Find Backward Again
To repeat the previous search, select the "Find Again" command. The next item 
matching the previous search will be found. This command is only available if you 
have previously searched for something. It searches in the same direction as the 
last Find. The search begins where the last search left off, or with the item that was



most recently “touched” in the list (e.g. the item that was last edited).

Remove Finished Item(s) or Remove Selected Finished Item(s)
If no items are currently selected, this command deletes all of the items in the list 
that are currently checked-off or “finished”. If any items are currently selected, 
only finished items among the selected items are deleted. This command is 
disabled if there are no finished items in the selection or complete list. If the 
Confirm Before Deleting Item(s) preference is on, you’ll be warned before the 
items are deleted.

The Sound Menu

 

ecord New Memo...
This command brings up a recording control panel and creates a new item with the 
recorded memo and default text indicating the date and time when the memo was 
recorded and its length in seconds.

Play Memo
This command plays the audio memo associated with the currently selected item. 
This menu command is only enabled when exactly one item is currently selected 
and that item has a recording.

Erase Memo(s)
This command erases the audio memo associated with the currently selected item 
or items. This menu command is only enabled when one or more items are 
currently selected and at least one has a recording.

Read Today's Items
This command uses the Speech Manager to read all of the unfinished items for the 
current date. If any of the unfinished items have recordings, the audio is also 
played. This item isn’t enabled if the Speech Manager isn’t currently installed (part
of System 7.5).



Read All Items or Read Selected Items
If no items are currently selected, this command uses the Speech Manager to read 
all of the unfinished items in the list. If any items are currently selected, only 
unfinished items among the selected items are read. If dates are displayed in the 
document, then it also reads the dates. If any of the unfinished items have 
recordings, the audio is also played. This item isn’t enabled if the Speech Manager 
isn’t currently installed.

The Window Menu

This dynamic menu contains one entry for each open ToDo List document. Just 
select the document's name in the menu to bring that document to the front. The 
document name’s are listed in alphabetical order. The document that is currently 
frontmost (active) will have a check next to it in the menu.

You can also use the Window menu to check which documents you’ve changed; 
documents with changes appear underlined until they are saved.


